Triangular wave and print area



  • good morning to all of you, I think I am in the right section.

    I'm here asking you for help with a print bed calibration problem, it's a bit of a pain to find I assume it's a mechanical problem. My printer is a tronxy X5SA Pro with electronics reconverted with duet 2 wifi, volume 330x330mm composed of BLTouch V3.1 as a probe and 3mm glass as a print bed, I have had it for a long time and it is two months now that I try in every way but to no avail, having noticed that the carriage where the extruder is attached was not very loose so I disassembled all the upper deck X / Y I cleaned them and I looked at the eccentrics and fixing them, now the skates seem to slide linearly on the tracks.
    The problem believed by the X / Y axes has not been solved, I pass to the second hypothesis "Axis Z" the printing table is quite rigid "modification made some time ago by replacing linear bearings with metal ones" and is synchronized by a GT2 6mm belt, I have no wobble problems, I also included the gearbox of the 2 motors "I also included the hardware as a problem" that control the screws and I cleaned everything with the WD40. I made sure once everything was mounted to oil the screws and freehand I made sure that the Z plane ran freely, but this doesn't seem to work either, I arrived at all this after trying to probe the print plane
    both hot and cold without changes in the survey, I tested without glass, on bare and raw aluminum, I also tried various survey speeds but the results are all negative, I am attaching photos and configuration of my system, I hope that some of you are able to solve the problem.

    I forgot: I tried to probe with various meshes, 60x60 and 40x40 no graphic visual problems, but at the time of printing some points seem to be high with tragic consequences on the final print. 20x20 here we begin to graphically see a triangular wave (which is the mangy problem in question).
    I remain at your disposal, thank you in advance.

    Photo below: 20x20 at 90 degrees celsius.
    20x20 temperatura 90 gradi.jpg

    Photo below: 20x20 at room temperature.
    20x20 temperatura ambiente.jpg

    Under the configuration files and the board diagnostics.
    retractprobe.txt homez.txt homey.txt homex.txt homeall.txt diagnostic.txt deployprobe.txt Config.txt Bed.txt



  • first check if the problem is your probe

    https://forum.duet3d.com/topic/6962/m48-measure-z-probe-repeatability-and-print-to-serial-output

    also decrease the probing speed to F120



  • thanks for the help, now I check, and for the diving speed as I had already written they do not change, I have already tried at 120, at 250 I have never had problems, but anyway I will try and I will give you the results



  • ok i tried and this is the result on 4 points, but how can it help me to know this?

    25/10/2020, 19:19:17 G32 bed probe heights: 0.195 0.190 0.190 0.190 0.188 0.188 0.192 0.190 0.190 0.000, mean 0.171, deviation from mean 0.057
    25/10/2020, 19:18:48 G32 bed probe heights: 0.202 0.202 0.200 0.200 0.198 0.198 0.200 0.200 0.195 0.000, mean 0.179, deviation from mean 0.060
    25/10/2020, 19:18:20 G32 bed probe heights: 0.188 0.185 0.180 0.185 0.178 0.178 0.183 0.180 0.183 0.000, mean 0.164, deviation from mean 0.055
    25/10/2020, 19:17:52 G32 bed probe heights: 0.198 0.195 0.198 0.192 0.192 0.198 0.198 0.198 0.192 0.000, mean 0.176, deviation from mean 0.059



  • the last measurement is very odd.
    did you copy the macro correctly?



  • I created the macro M48.g in sys, then I created a macro where it indicates the coordinates and calls M48, but it doesn't work for me, instead of dwelling on a precise point it goes diagonally, I read that a G30 with parameter P wants the coordinates, so I created one with the coordinates and it works, I'll post the macro





  • G30 P9 X165 Y30 Z- 9999

    there is a space to much after the Z-



  • ok, I'll call you hawkeye, correct and take the test again



  • 25/10/2020, 19:37:22 G32 bed probe heights: 0.190 0.198 0.195 0.195 0.192 0.192 0.190 0.195 0.188 0.192, mean 0.193, deviation from mean 0.003
    25/10/2020, 19:36:52 G32 bed probe heights: 0.195 0.195 0.192 0.202 0.212 0.208 0.205 0.200 0.200 0.198, mean 0.201, deviation from mean 0.006
    25/10/2020, 19:36:22 G32 bed probe heights: 0.188 0.178 0.178 0.178 0.178 0.178 0.173 0.178 0.183 0.180, mean 0.179, deviation from mean 0.004
    25/10/2020, 19:35:52 M98 P"0:/macros/Calibrazione a punto singolo/Calibrazione x 10"
    G32 bed probe heights: 0.190 0.192 0.192 0.195 0.190 0.185 0.190 0.188 0.188 0.190, mean 0.190, deviation from mean 0.003



  • ok that looks good.

    now do the test again, grab the hotend carriage and turn on clockwise and anticlockwise between probes. dont force it but do it gently.

    after that do it again trying to rotate it forwards and backwards.



  • in practice I take the trolley and manually try to move it and then I do the tests again, did I understand correctly?



  • @Leblond
    yes. we are looking for backlash in the assembly. movement could cause the assembly to rotate and cause the result you are seeing.



  • 25/10/2020, 19:57:24 G32 bed probe heights: 0.192 0.195 0.190 0.192 0.192 0.192 0.190 0.190 0.190 0.190, mean 0.191, deviation from mean 0.002
    25/10/2020, 19:56:50 G32 bed probe heights: 0.183 0.185 0.180 0.185 0.185 0.183 0.183 0.183 0.185 0.183, mean 0.183, deviation from mean 0.002
    25/10/2020, 19:56:17 G32 bed probe heights: 0.168 0.168 0.168 0.173 0.170 0.165 0.170 0.170 0.170 0.170, mean 0.169, deviation from mean 0.002
    25/10/2020, 19:55:43 M98 P"0:/macros/Calibrazione a punto singolo/Calibrazione x 10"
    G32 bed probe heights: 0.183 0.185 0.183 0.185 0.185 0.185 0.183 0.185 0.185 0.183, mean 0.184, deviation from mean 0.001



  • M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent

    there are default values from the configurator.

    a quick google shows the motors seem to be 1,68 A motors

    so you are running way to little current. try 1300



  • The motors are Quimat Nema 17 Stepper Motor 1.7 A 0.59 Nm 84 oz.in 47mm



  • @Leblond said in Triangular wave and print area:

    1.7 A

    so running them at 75% rounding to nearest 100 is 1300.



  • ok I took them to 1.3 and I'm doing the test again later



  • 25/10/2020, 20:56:11 G32 bed probe heights: 0.198 0.195 0.195 0.198 0.195 0.200 0.195 0.200 0.192 0.195, mean 0.196, deviation from mean 0.002
    25/10/2020, 20:55:37 G32 bed probe heights: 0.183 0.180 0.180 0.183 0.183 0.183 0.183 0.180 0.180 0.183, mean 0.181, deviation from mean 0.001
    25/10/2020, 20:55:04 G32 bed probe heights: 0.183 0.178 0.173 0.170 0.178 0.173 0.173 0.178 0.178 0.173, mean 0.175, deviation from mean 0.004
    25/10/2020, 20:54:31 M98 P"0:/macros/Calibrazione a punto singolo/Calibrazione x 10"
    G32 bed probe heights: 0.195 0.192 0.192 0.195 0.192 0.195 0.195 0.195 0.188 0.195, mean 0.194, deviation from mean 0.002



  • I'm retrying cold-meshing the plate to see if we've made any improvements



  • 20x20 temperatura ambiente_secondo tentativo.jpg



  • no improvement



  • it seems to be very consistent.

    can you turn the glass 90 degrees?



  • Is the X carriage on wheels?
    I'm not familiar with the printer and can't tell from the photos I've seen,
    Almost looks like an eccentric wheel causing the nozzle to rise & fall with each rotation



  • 20201026_131106.jpg
    20201026_131116.jpg


Log in to reply