Problems with the E3D-V6 Temperature



  • Hi

    i have installed today the E3D-V6 all wired correct.

    now if i set in active the temperature of 195 Celsius the Temperature goes up to 220 celsius

    i got this error:
    Error: Heating fault on heater 1,temperature excursion exceeded 15.0 Calsius

    this is my config.g:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Dec 15 2018 20:53:32 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PAM8 ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-363335" P"luigello20101984" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100 Y100 Z400 E100 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X24000 Y24000 Z480 E3000 ; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z100 E10000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-34 Y-1,5 Z0 S1 ; Set axis minima
    M208 X220 Y216 Z220 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P5 H5 F0 T6000 ; Set Z probe type to switch and the dive height + speeds
    M557 X5:215 Y20:195 S42:35 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 B4725 C7.060000e-8 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S28 0 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F100 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0.75 I0 F500 H0 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hotend" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured
    ;M671 X3:2017:217 Y108:3:2013 P0.5
    M404 N1.75 D0.4
    M376 H10
    M207 S3.5 F1920 Z0.0

    ;Miscellanous
    T0

    please i need some help since 3 hours and no results

    thanks a lot



  • Hi,

    Did you run the heater tuning procedure (see M303) ?

    Frederick



  • @fcwilt said in Problems with the E3D-V6 Temperature:

    heater tuning procedure (see M30

    yes but my english is not the best to understand the procedure

    can you help me a bit ?



  • In the GCODE terminal type:

    "M303 H1 S200"

    Then when finished type

    "M500"





  • i got this

    23:13:25Auto tune phase 3, peak temperature was 221.4
    23:13:19Auto tune phase 2, heater off
    23:10:11Auto tune phase 1, heater on
    23:10:05M303 H1 P0.5 S240
    Auto tuning heater 1 using target temperature 240.0°C and PWM 0.50 - do not leave printer unattended



  • @lui2004 said in Problems with the E3D-V6 Temperature:

    You have multiple mistakes in your config file:

    ; Axis Limits
    M208 X-34 Y-1,5 Z0 S1 ; Set axis minima

    M143 H1 S28 0 ; Set temperature limit for heater 1 to 280C



  • @sigxcpu said in Problems with the E3D-V6 Temperature:

    ; Axis Limits
    M208 X-34 Y-1,5 Z0 S1 ; Set axis minima

    ; Axis Limits
    M208 X-34 Y-1,5 Z0 S1 ; Set axis minima
    whats wrong here ?



  • @lui2004 Possibly the comma instead of a period. , versus .



  • Now i See my mistake.

    And for E3d-v6 What i can do to solve my problem any idea?



  • If it really is an authentic E3D hotend and thermistor I think your M305 settings are off.

    You have M305 P1 B4725 C7.060000e-8
    But should have M305 P1 T100000 B4388 C7.060000e-8 R4700 Or at least that's what the configurator gives for the semitek thermistor E3D uses.



  • @phaedrux said in Problems with the E3D-V6 Temperature:

    M305 P1 T100000 B4388 C7.060000e-8 R4700

    ok i have change it

    send this gcode for autotuning:
    M303 H1 S240

    result:

    Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 472C.
    Auto tune heater 1 completed in 223 sec
    Use M307 H1 to see the result, or M500 to save the result in config-override.g

    Gcode M307 H1 Result is:

    M307 H1
    Heater 1 model: gain 447.7, time constant 133.2, dead time 13.0, max PWM 1.00, calibration voltage 12.3, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P4.1, I0.098, D37.2
    Computed PID parameters for load change: P4.1



  • Have you double check voltage of termopar/PSU printer?



  • That looks like a normal warning. Is the temp stable now or does it still fault?



  • till 5 minutes 235C stable

    i will make a test print



  • seems to be ok still print the calibration cube

    other thin my print is not in the center of my bed





  • @lui2004 said in Problems with the E3D-V6 Temperature:

    Now i See my mistake.

    And for E3d-v6 What i can do to solve my problem any idea?

    I assume you fixed this one too?

    M143 H1 S28 0 ; Set temperature limit for heater 1 to 280C



  • Yes i fix it


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.