Printer pausing 1-3 sec every ~10 print moves



  • Hello everybody,

    Recently I swapped the motherboard of my proprietary Zortrax printer with a Duet.

    Everything is working and I have been able to print. However, after every few movements, the printer pauses 1~3 sec and than continues.

    It looks like a simillar phenomenon as described in various older posts, such as (https://forum.duet3d.com/topic/1258/duet-0-8-5-freezing-during-print).

    The common theme in the threads I have found seems to be interference, but that being the culprit has yet to be proven.

    The printer (Zortrax Z200) is a very standard, all-metal cartesian printer using fairly common components.

    The only thing unusual in my setup is that all my wires are a bit longer than usual to accomodate for an enclosed chamber.

    I will upgrade it to 3.0 tonight but I am skeptical it will affect behaviour.

    PS I am considering to try and rule out potential causes by printing with no extrusion, no bed heat, and hotend disabled to rule out some components (dry run). Perhaps attaching a scope to VIN or elsewhere might lead to some clues, but I'm not sure what to look for.

    Does anybody have an idea where to start troubleshooting? I do have a simple InstruStar USB oscilliscope and various capacitors, resistors etc to play around with.

    Currently on FW version 3.0beta1.
    Board: Duet 2 Ethernet, bought last week.

    Any suggestions are appreciated.



  • Most probably you have Mesh bed leveling enabled (G29 S1) and is your Z jerk too low causing the "freezing".
    Please post your config.g contents



  • I checked, and no M29 command is used in any of the .gcode/.g files. Could it still be the Z-jerk setting? This is in my configuration file:

    M566 X900.00 Y900.00 Z12.00 E120.00
    

    Just to be sure I soldered the VIN connections to the board and updated to beta2, still the same behaviour.

    I made a video to illustrate the behaviour:

    https://youtu.be/ct2_15tFM5w



  • check that you are using x16 with interpolation for all drivers. sometimes people like to configure high microstepping and its overloading the cpu.

    also please update to the release firmware.

    there were a lot of changes and bugs in the earlier firmwares.



  • @whosrdaddy here is the config file: https://pastebin.com/ACg8bm6p

    @Veti I believe microstepping is set to x16 with interpolation.

    @Veti I am at 3.01beta2 (aka 3.0beta2). That is the one I should be on right?



  • @HC3D

    I would increase your acceleration from M201 Z20 to Z100.
    I would also probably increase your jerk M566 from Z12 to Z24



  • Yes, Z values are too low and will cause this issue...


  • Moderator

    @HC3D I don't see your bed trying to move at each pause, and if it was related to bed levelling, it wouldn't print around the whole object, then pause moving between two close objects. It seems to pause before moving to a more complex object to print, eg a circle, like it's running out of commands to print. How are you running the print? Do you select it in the DWC interface, or are you sending it via USB/Octoprint? Can you post the gcode file, to see if there's anything different about it?

    Also, not related, but your using the default thermistor values on your bed heater:

    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp

    This will be inaccurately reporting bed temperature. Find out what thermistor you have and update your config.g with the correct beta value.

    Ian



  • Have you tried printing with retraction disabled/set to 0mm in your slicer just to check if keeps pausing then ?



  • What slicer program are you using and which version. Cura 4.0 had a bug that would cause your exact behavior, which was fixed in later releases.



  • After switching from Simplify3D, which I had used for a long time with another printer, to KISSlicer, the mentioned problems went away.
    I have since then switched to Cura, which also does not have freezing issues.

    For the record, here are my g-code files:

    Model sliced in KISSLICER
    Model sliced in Simplify3D


  • administrators

    In your S3D file I notice that your retraction and reprime speed is just 0.6mm per second. This is very slow. Even though you are only using 0.8mm retraction, this means that each retract/reprime cycle will take around 2.7 seconds. Does this explain the pauses?



  • @dc42 That must be it. Thanks for pointing out!



  • Now with Cura, the problem turns out to still be there.

    @jay_s_uk @whosrdaddy, OK, I performed your suggested changes. The problem is still there, but I will keep those new values.
    @droftarts I am printing by transferring the files using DWC first. I noticed my G-code file is fairly large, for example 11MB for a 45-minute print. Your hypothesis that the system is not able to handle the command rate is a possibility
    @dc43 In cura, I am using a retraction speeds of 50mm/s, so retraction must not be causing issues now.

    Perhaps the 11MB GCODE file is too dense for my system to process? My CAD tool cranks out a fairly high number of polygons; my STL output setting is fairly high.

    Here is a video when printing a Cura-generated file: https://youtu.be/W3kOFaIqv9E
    Here is the G-code file: https://www.mediafire.com/file/yua9zzaew00neom/CFFFP_Part1.gcode/file
    Here is the STL file: https://www.mediafire.com/file/2fy9i8nwts74eba/Part1.STL/file

    Any ideas as to what could be going on?



  • @HC3D said in Printer pausing 1-3 sec every ~10 print moves:

    Now with Cura, the problem turns out to still be there.

    @jay_s_uk @whosrdaddy, OK, I performed your suggested changes. The problem is still there, but I will keep those new values.
    @droftarts I am printing by transferring the files using DWC first. I noticed my G-code file is fairly large, for example 11MB for a 45-minute print. Your hypothesis that the system is not able to handle the command rate is a possibility
    @dc43 In cura, I am using a retraction speeds of 50mm/s, so retraction must not be causing issues now.

    Perhaps the 11MB GCODE file is too dense for my system to process? My CAD tool cranks out a fairly high number of polygons; my STL output setting is fairly high.

    Here is a video when printing a Cura-generated file: https://youtu.be/W3kOFaIqv9E
    Here is the G-code file: https://www.mediafire.com/file/yua9zzaew00neom/CFFFP_Part1.gcode/file
    Here is the STL file: https://www.mediafire.com/file/2fy9i8nwts74eba/Part1.STL/file

    Any ideas as to what could be going on?

    Took a quick look at the GCODE you posted, can you verify if you mean to set the GCODE flavor to Marlin in Cura?
    ;FLAVOR:Marlin
    If not, you can change it to RepRap under "Machine Settings"
    948628be-a262-49f9-b7a4-e1142aa90550-image.png



  • @sebkritikel Ah, I see that Cura is configured to use Marlin flavor on my installation. I overlooked this setting.

    As a test I switched it to RepRap and threw it in a diff tool. The main difference seems to be relative extrusion being used on RepRap while Marlin uses absolute extrusion. Could that be causing the freezes?

    I suppose I could do a test with the new G-code generated in RepRap flavor.


  • Moderator

    Yes please generate a new gcode using cura set to reprap flavour. Also check the start gcode for any speed settings being inserted by cura and delete them.

    And please post your latest config.g.

    And if you're still running 3.01beta2 I suggest updating to 3.01RC4.


  • Moderator

    If your previous config is still accurate I would change the Z and E axis speed settings as follows:

    M566 Z120 E1200           ; set maximum instantaneous speed changes (mm/min)
    M203 Z600 E4000        ; set maximum speeds (mm/min)
    M201 Z120 E2500            ; set accelerations (mm/s^2)
    

    Your original values were very very conservative and could explain the long delays on retractions and layer changes.

    M566 Z12.00 E120.00            ; set maximum instantaneous speed changes (mm/min)
    M203 Z180.00 E1200.00        ; set maximum speeds (mm/min)
    M201 Z20.00 E250.00            ; set accelerations (mm/s^2)
    

Log in to reply